Improve Simultaneous Ring Settings and Functionality

  • 2
  • 4
  • Idea
  • Updated 3 months ago
Currently simultaneous ring has two issues:
1. If configured with desktop app to ring more than 0 seconds it will ignore the setting and ring sequentially instead of simultaneously. The number of seconds should be ignored if it is simultaneous!
2. If a device cannot be reached it may go to voicemail instead of recognizing the device is unavailable. See https://community.ringcentral.com/ringcentral/topics/simultaneous-ringing-issue

To fix #1 it is recommended that the seconds settings be disabled for all but the controlling line when simultaneous ring is enabled.

To fix #2 it is recommended that a setting be added that if the line rings an unavailable tone or instant pickup such as redirect o voicemail is detected then the line is dropped in the ringing continues for the user to the other lines.
Photo of Kevin Hart

Kevin Hart

  • 1,100 Points 1k badge 2x thumb
  • hopeful

Posted 2 years ago

  • 2
  • 4
Photo of Steve Keyros

Steve Keyros

  • 62 Points
I could not agree more with Kevin. This should not be an idea, but expected behavior. After testing the implementation of desk phones in addition to soft phones and not understanding why my phones are ringing sequentially although set to simultaneous, I found this article. 

Photo of Brian Scheele

Brian Scheele

  • 174 Points 100 badge 2x thumb
Seriously, this should be fixed.  This is something that we give users access to change, so it should not be bugged and not behave as it appears it should behave on the config screen.  IT and phone admins who are used to looking at this stuff should not be confused as to why this is not working.

I currently have users working at home during the COVID-19 outbreak, where multiple people have to field receptionist calls - not just the one user who has been assigned that phone.  It rings apps and cell phones simultaneously according to how I have it configured, but it is not until 20 seconds that cell phones begin to ring.  

This is not a feature request - this is a "fix your broken/confusing config" request!  Or, show some sort of output that shows how it will actually function based on what you have chosen.