ISSUE - Plantronics Headset Active Noise Canceling NOT working when using ringcentral desktop for Windows

  • 0
  • 1
  • Question
  • Updated 5 years ago
  • Answered
Merged

This conversation has been merged. Please reference the main conversation: Help with Unsupported or 3rd party equipment.

I have 10 Plantronics Voyager Legends UC's that my users use with their Ring Central desktop phones for Windows 8.  These are being used on a business class HP pc and are connected via a Plantronics Blue tooth dongle.


Here is the problem....and it is serious!  The active noise canceling is NOT working when on ringcentral.  The headsets work perfect when paired with a cell phone.  But on the PC rincentral app, clients complain that they can here everything in the background. 

I tested it myself and you can hear absolutely everything in the background.....like even a needle dropping!


This is a HUGE problem that I need resolved immediately!


I tried for hours to fix this via the control panel and making adjustments to the Sound settings (enabling and disabling features and settings).....NO LUCK!

Please help!!

Photo of Demirel Insurance

Demirel Insurance

  • 82 Points 75 badge 2x thumb
  • PISSED and SAD!

Posted 5 years ago

  • 0
  • 1
Photo of Mike

Mike, Official Rep

  • 94,910 Points 50k badge 2x thumb
This sounds like an issue you will want to contact Plantronics for. There's nothing in the RC Desktop software that controls any audio settings in any 3rd party headset. I'll move this post to another thread were you might get help from other Community members. 

This conversation is no longer open for comments or replies.