New RC Widget and Google Chrome integration

  • 0
  • 1
  • Question
  • Updated 4 months ago
  • Acknowledged
Ever since we switched to the new RingCentral for Salesforce App, we have been having issues with the widget functioning.  Most of my agents have blue screens and some have limited functionality with call logs and caller id.  I have had my SF Admin on a conference call with Level 2 Tech Support and it was determined that it had nothing to do with SF or Admin settings. It has now been escalated to level 3 Tech Support while they try to figure out why.  They think that it has to do with its integration with Chrome.  This has been going on now for 3 weeks.  Has anyone else experienced this issue.  I'm getting very frustrated and am looking for a back-up provider if this does not get resolved ASAP.
Photo of RAU

RAU

  • 180 Points 100 badge 2x thumb
  • VERY frustrated

Posted 6 months ago

  • 0
  • 1
Photo of Brandon

Brandon, Champion

  • 19,508 Points 10k badge 2x thumb
I have not used the SF app myself, but you mentioned Chrome and there is a brand new preview for a rebuilt Chrome app you might be interested to check into if you were not already aware: https://chrome.google.com/webstore/detail/ringcentral-for-google-pr/ogajfdkabekkakncbfjlppecgjfajnfn
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 39,034 Points 20k badge 2x thumb
Sorry for the frustration, RAU. I see that you have a case open with us and it has been escalated to our Integrations team. Once they review the case information they should be contacting you
Photo of RAU

RAU

  • 180 Points 100 badge 2x thumb
Yeah.... I just got an email that said that it was a configuration issue in SF and that they wanted a meeting with my SF Admin.  We had a video conference call last Thursday with my SF admin that erased all doubt that it had anything to do with SF.  Please look deeper.
(Edited)
Photo of Saadet - Community Support

Saadet - Community Support, Official Rep

  • 38,106 Points 20k badge 2x thumb
I would suggest you follow up with our Integration team on that so that they can continue to investigate
Photo of RAU

RAU

  • 180 Points 100 badge 2x thumb
I already sent a reply.
Photo of Jeremy Thompson

Jeremy Thompson

  • 314 Points 250 badge 2x thumb
It's really stable for us, but we primarily use our wired desk phones to talk. We don't talk through our computers (which are on our wireless network). I found when you do that, it's just asking for trouble. I also found that when we use the chrome app to talk through our computers, calls get dropped. I have a hunch that VOIP isn't meant for wireless networks.