How to switch Softphone ringer from headset to PC speakers?

  • 0
  • 2
  • Question
  • Updated 2 months ago
  • Answered
  • (Edited)
The desktop app should have the option to ring PC/laptop speakers even when headset is plugged in. 

I believe this feature was available in the old softphone version. 
Please make this "ring PC speakers" available so we don't have to keep plugging and unplugging our headset each time we leave our desk. 

If this feature is available in the current desktop app, then please email me back with instructions on how to set it. 
The tech support person I chatted with told me ringing PC/Laptop speakers while headset is plugged in does not work. 

Appreciate your looking into this. 
thanks 
Photo of Holistic360

Holistic360

  • 132 Points 100 badge 2x thumb

Posted 3 years ago

  • 0
  • 2
Photo of Andrew

Andrew, Champion

  • 2,696 Points 2k badge 2x thumb
This definitely works. Just set the ringer to the speaker you want to ring and not to the system default. That's all that's needed :)
Photo of Mike

Mike, Official Rep

  • 94,910 Points 50k badge 2x thumb
1. Just click the Settings icon,.




2. Then Sound, and you'll see the drop-down to choose the Ringer of your choice.

(Edited)
Photo of Holistic360

Holistic360

  • 132 Points 100 badge 2x thumb
I tried this before I called this in but it didn't work.  It still rings to my headset (3.5mm same as the one i use on my cellphone) when it is plugged in. Don't know if there is a need to adjust something on my laptop settings itself.
Photo of Lucas Taylor

Lucas Taylor

  • 100 Points 100 badge 2x thumb
I have this exact same issue, but if I change the PC default to speakers it plays my call audio through my speakers no matter what ringcentral output option I select. I try every single ring option in the app and it always just rings to my headset if I dont change the default
Photo of Lucas Taylor

Lucas Taylor

  • 100 Points 100 badge 2x thumb
Update, i ended up finding a backdoor solution in sound settings that allowed for simultaneous audio through two sources, but it is real annoying. There has to be an easier fix.
Photo of Michael Lepurage

Michael Lepurage

  • 62 Points
Same issue as Lucas. My default output is set to PC speakers and the RingCentral Phone app is also set to PC speakers, yet it only rings to my headset (plugged in via USB).
Photo of Lucas Taylor

Lucas Taylor

  • 100 Points 100 badge 2x thumb
Try: Control panel > Hardware and Sound > Sound > Recording Tab

There should be a device called Stereo mix. Open it up to make sure it is activated, and once it is activated you can set the options to play out of multiple audio outputs.
Photo of Michael Lepurage

Michael Lepurage

  • 62 Points
So, I do have Stereo Mix enabled. However, I noticed something interesting. My company uses inContact for calls (which hooks up to RingCentral). When I made an outbound call, the RingCentral ringer played on my speakers. Perhaps the RIngCentral settings functionality itself is just broken. I will find out when I receive an inbound call in about 20 minutes.