Mobile App: Unable to set VoIP Calling on the RingCentral mobile app

  • 0
  • 2
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
I have the RingCentral Professional Plan in Canada, using an iPhone on the Rogers Network, wi-fi is ON, RingCentral app version 8.2.0.1.35 (44.2.5). I am unable to receive incoming VOIP calls on the mobile app. It does not ring. Notifications for the app are enabled. First ring "Desktop and Smartphones" is set to ON. On "My Profile" I see "Ringout settings", but I do not see a VOIP Calling menu option as I see in other screenshots from older posts, nor the "Data (VOIP) Calling" option on the knowledge base Article Number : 4044. Any ideas?
Photo of Erick Oliveira

Erick Oliveira

  • 120 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 2
Photo of Kim

Kim, Alum

  • 43,000 Points 20k badge 2x thumb
Under First Ring Desktop App & Smartphone, how many rings it is set to? 
Also check user hours & regional settings (timezone). 
Photo of Erick Oliveira

Erick Oliveira

  • 120 Points 100 badge 2x thumb
Hi Kim! "Wait before forward begins": 10 seconds. User hours are set to 24 hours.
Photo of Kim

Kim, Alum

  • 42,766 Points 20k badge 2x thumb
So your extension is set to ring the Smartphone App for 10 seconds, then it's set to roll over to your cell phone.  So that is why the calls are coming in on your cell phone. 

I recommend adding a number to your extension (you can add just a number and not a full Digital Line) and then login in to your extension directly. 
Photo of Brandon

Brandon, Champion

  • 17,294 Points 10k badge 2x thumb
You need to be logged in with a user account that has a digital line to have voip calling as I understand.  I think this may be the reason.  Do you have a direct digital line you can try logging in with?
Photo of Erick Oliveira

Erick Oliveira

  • 120 Points 100 badge 2x thumb
I have an extension number (i.e. 1) . In the app I am logged in with the company main number and the extension number (I just logged out and logged in again to make sure). I do not have a second digital line to try if this would be the fix.
Photo of Kim

Kim, Alum

  • 42,766 Points 20k badge 2x thumb
Correct.  Erick you will need to add a number to your extension and then log in with that (not the super admin credentials). 
Photo of Erick Oliveira

Erick Oliveira

  • 120 Points 100 badge 2x thumb
Gents, just to give some feedback and let this info be useful for other researching this forum: We added the number to the extension and it did not solve the problem. Further contact with the RIng Central team made us aware that incoming VOIP calls are not available on the RingCentral Professional Plan, at least in Canada. So, after a change in the Plan, incoming VOIP calls are now working. Thanks everyone for the help!
(Edited)
Photo of Michael Larssen

Michael Larssen

  • 366 Points 250 badge 2x thumb
Because it rings on the mobile ap and I have to forward, I don't use the then forward call to option. I have notify ny desktop and smartphone on and wait 15 seconds before forwarding begins but mobile number is not active??