Incorrect account information when resetting password for Production app

  • 14 June 2018
  • 3 replies

Finally, I was able to publish my app to Production. However how many times I tried, I got the same error "Incorrect account information." when Resetting Password.

My sandbox app is working as expected. I also tried using current RingCentral password of production account which I always used to sign into but then got an error when requesting a token


"error" : "invalid_grant",

"error_description" : "Invalid resource owner credentials",

"errors" : [ {

"errorCode" : "OAU-140",

"message" : "Invalid resource owner credentials"

} ]


3 replies

Hi Thuy,

Please note that you can not use sandbox account for production or vice versa.  It seems that you are aware of this.

"Invalid resource owner credentials" means username or password is wrong.  In theory, as long as you can login , you should also be able to get a token.

Could you please show me how did you try to request a token? Show me some sample code (do NOT post your password here).

Hi Long,

Yes, sandbox account and production account are different. I clicked on Reset Password of the Production one and I was not able to reset password with error  "Incorrect account information."

I used password flow to get a toke and was able to request a token using sandbox account. Following is the code to request a token (I used RestSharp)

 var client = new RestClient("");
            client.Authenticator = new HttpBasicAuthenticator("production-app-id", "production-app-secret");
            var request = new RestRequest("/restapi/oauth/token", Method.POST);
            request.AddHeader("Content-Type", "application/x-www-form-urlencoded");
            request.AddParameter("grant_type", "password");
            request.AddParameter("username", "+16xxxxxxx01");
            request.AddParameter("extension", "101");
            request.AddParameter("password", "production-password");
            var response = client.Post(request);


I am running in to the same issue when trying to move from our Sandbox to Production. I have tried the workarounds above. When I try to just enter the account number without the extension, I receive a warning that our account has SSO enabled. I then log in via SSO and am just brought to the home page of RC.

Our application is using the password flow, so we need to be able to reset the password for our account so we can get our access and refresh tokens for the Production environment. We have a ticket open with support and have gotten no where.

How can we reset the extension 101 account's password? Is there another workaround?