guy4pigplay14091 avatar image
guy4pigplay14091 Suspended asked Becky-Community_Manager commented

Unable to log in to RingCentral Meetings from one Mac. Problem is identical to Eduardo's

About 4 days ago, RingCentral Meetings on one of my Macs (MacMini i7, 16GB, running OSX 10.11.6) started exhibiting the same behavior as reported in the community forum by at least a half dozen users now. Every time I try to log in, RC Meetings reports I am not connected to the Internet, and I need to check my network connection. My Internet connection works just fine because I can connect to every other Internet service or website I use. I can even connect to the RingCentral Glip app. Because I can't log in, I am unable to connect to meetings and the floating window with Join Meeting / Start Meeting buttons won't load. FYI: I am running RC Meetings for Mac version 6.3.135305.1213, which is the most recent version as reported by the application itself.

At first, I thought the issue might be an account problem, but my tests demonstrated that wasn't the case. I was able to log in to my account from the web at Next, I attempted to use RC Meetings from my Mac laptop. Everything worked perfectly.

Now for the real clincher, I can log in to RC Meetings, and it works beautifully on the same Mac where I'm experiencing this issue when I boot the Mac from an external SSD running a slightly earlier version of MacOSX (version 10.10). The only variation I have noted is a report by the MacOS network traffic inspection utility, Little Snitch, which reports RC Meeting's digital signature is different when running from the external SSD partition than when booting from my primary internal SSD. Little Snitch's messaging is a bit cryptic, but it suggests the application isn't signed on the Mac partition I can't log in from. I opened the application package and did some snooping around, and I discovered this in the plist XML:

It kind of looks like there might be something missing, don't you think? Of course, I might be barking up the wrong tree, but I've given you a whole bunch of information to investigate and resolve this issue.

Let's review. I eliminated all of these possible variables:

  • Not a firewall issue: No firewall in operation; no ports are blocked.
  • Not an account issue: I can log in to my account from I can log in from my Mac laptop. I can log in on the Mac I'm experiencing the problem on when booting from an external SSD with an alternative version of the OS.
  • Not a router or ISP issue: All testing has been accomplished using the same router and ISP.
  • Not a computer hardware issue: I can connect from the same Mac that can't connect when booting a slightly earlier OS version from an external drive.

Jessica - If you are reading this I would argue you haven't been doing your job (or a very good job) by directing folks experiencing this issue to submit tickets to tech support. I have a free account, and I haven't found a way to submit a ticket or interact the support team on chat. I wanted to expedite resolution of this issue so I tried to buy a paid subscription two nights ago. I tried two different credit cards, but RC's payment gateway reported it couldn't process my cards. It wasn't telling me it could authorize charges to my card (which my bank would have notified me about) so it sounds like Ring Central' payment processing might be offline. No help there.

As a community evangelist, it's your role, Jessica, to act as a facilitator who elevates customer concerns so they get the visibility within your support organization necessary for quick resolution. I am very glad to see that you created a ticket for Edoardo Tuo, who IMHO was treated in a condescending, unhelpful manner by J.B. Ferguson, who, again in IMHO, is not the kind of person you want representing RingCentral and its brand.

Right now, I have a very lukewarm opinion of RingCentral's customer service and support organization, which is a great opportunity for you to convert me from a skeptic to a fan. I'd start by forwarding my email to your executive response team so they can connect with your developers in hopes of getting this issue resolved quickly and easily for everyone experiencing it.

Please send me the ticket number if you create a ticket for me. Thank you, and I look forward to hearing from you or someone else at RingCentral.

Len F.

1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

trevor-parks avatar image
trevor-parks Suspended answered
Identical problem with new MAC with most recent updates installed.
1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

J.B. Ferguson avatar image
J.B. Ferguson answered Becky-Community_Manager commented
For the record, I am NOT a RingCentral employee nor do I represent RIngCentral and it's brand. I am a customer, just like those with paid accounts, who tries to help out here in the community based on our experiences and knowledge of the system.  I am not paid by RIngCentral nor compensated with a free account or anything else to help out here.

Furthermore, my responses to Mr. Tuo were hardly condescending and it seems that those in the community are only "helpful" in your eyes if they solve a person's issue. I simply made recommendations and asked questions, which only one question of the ones I asked was answered by Mr. Tuo. My track record of helpful responses speaks for itself with 887 likes on 1,410 responses.

You, of course, are entitled to YOUR opinion. But unless you work or have worked at RIngCentral and know what Jessica's job description is and what her job entails, I would only conclude that your comments to her were very condescending and certainly were not helpful.

I'm done with this entire issue.

1 comment
1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Becky-Community_Manager avatar image Becky-Community_Manager ♦♦ commented ·
We appreciate your support, J.B.

1 Like 1 ·
jessica-community-moderator avatar image
jessica-community-moderator answered marcus-boggs commented
Hi Len, 

I have escalated your issue to our Executive Response Team. Your case number is 08286495 and someone will be reaching out to you soon! 
1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

m-ch avatar image m-ch commented ·
Hi, Jessica - I'm not sure if this is the right way to do this, but I'm having the exact same problem.  When I try to login to Ring Central on my Mac, it tells me that I don't have an internet connection and to try again.  
0 Likes 0 ·
jessica-community-moderator avatar image jessica-community-moderator ♦♦ commented ·

Hi M,

This is a known issue that has been reported. Currently, there are a couple workarounds posted throughout Community. Make sure to check and see if you have both Zoom and RingCentral downloaded-- if you do, follow these steps:

  1. Click on the search option in the top right of your desktop
  2. Search for ~/Library/Preferences/ then select Preferences. This will open up the Finder.
  3. In Finder, search for the file named ZoomChat.plist
  4. Right click on 'ZoomChat.plist', and select Move to Trash.
  5. Uninstall RC Meetings. Back in Finder, navigate to Applications. Find RingCentral Meetings, right click and select Move to Trash.
  6. (If Applicable) Uninstall Zoom. Back in Finder, navigate to Applications. Find, right click and select Move to Trash.
  7. Right click on the Trash Can in the bottom right and select Empty Trash.
  8. Restart your Mac.
  9. Reinstall RingCentral Meeting which can be found here:

0 Likes 0 ·
jay-reed9663 avatar image jay-reed9663 commented ·
I know this is a common question, but is there any identified cause of this yet? It seems to be happening to random reps without any discernible pattern. 

If there's any more information for this issue, or if I'm looking in the wrong place for updates, please let me know. 
0 Likes 0 ·
jessica-community-moderator avatar image jessica-community-moderator ♦♦ commented ·
Hi Jay, 

It's tied to the plist with Zoom and the RC app. I don't have any more details beyond that. A permanent fix should be in place on our next meetings update (barring any major hiccups and bugs) 
0 Likes 0 ·
marcus-boggs avatar image marcus-boggs commented ·
Hi Jessica,
Thanks for your involvement with this issue.  I am having the same problem (i.e can't log in to RC Meetings, .check network connection, invalid meeting ID,etc).  However, I am running Mojave 10.14.5.   When I tried the troubleshooting steps above, I don't have a ZoomChat.plist file to delete,   I have deleted both Ring Central and Zoom files per the instructions.  Restarted. Reinstalled RC Meetings and the same issue occurs.

Please let me know if there are any other workarounds. 
Thank you !

M Boggs
0 Likes 0 ·
otterly-resilient14116 avatar image
otterly-resilient14116 Suspended answered nic-nc commented
Jessica I have the same problem as well 

1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

jessica-community-moderator avatar image jessica-community-moderator ♦♦ commented ·

There will be information posted in the threads referencing this issue, but there won't be a external email or anything of that nature sent. 


I know that Len and Edoardo have received phone calls, and the account information for all community members that have reported this issue have been provided to Support for more research. 

1 Like 1 ·
otterthisswirld14171 avatar image otterthisswirld14171 commented ·
Well don't worry about the user id being dedicated to ring, because it will stop working in a couple hours just as the rest did. I am currently on my 15th or 16th account. But I guess it will keep going up since RC doesn't seem to be able to fix the problem. 
1 Like 1 ·
nic-nc avatar image nic-nc commented ·
The only way I have Gotten consistently past the error was to use the "guest" account on my mac.Since that account resets (deletes all files and settings) on log-out, whatever the issue is, resets.The drawback is that it all resets. Your room list history, and personal settings return to their defaults. Maybe the culprit is the files that are generated after the first run of the application for each user.

1 Like 1 ·
jessica-community-moderator avatar image jessica-community-moderator ♦♦ commented ·
Hi Otterly, 

I'm currently working with ERT and  Support to get all the accounts who have posted about this issue looked at. Once I get more info, I'll update everyone :) 
0 Likes 0 ·
db2497 avatar image db2497 commented ·

Thanks Jessica. Will there be an announcement to update all Mac Users?


0 Likes 0 ·
Show more comments
cosshades-35414129 avatar image
cosshades-35414129 answered philly-boy commented
I, as well am having the same issue. Mac mini mid 2014, Mac OS 10.14.3 supplemental. Ring central is the only app that will not connect to the network. Just as above I can login to Meetings via my phone or the browser account page, just not the desktop app
1 comment
1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

philly-boy avatar image philly-boy commented ·
same here, apple says its the app itself not being undated for the 64 bit intel 
1 Like 1 ·
raw-d-nyc avatar image
raw-d-nyc Suspended answered
Same issue here. 2017 Retina 4k iMac Mojave 10.14.3
1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

adam-hughes14155 avatar image
adam-hughes14155 answered

As with everyone above I have similar issues. 

Mac is 2 years old, Mojave 10.14.3, the RingCentral Desktop app is up to date. 

I am unable to login to the RingCentral desktop app even though I am a PAYING customer! The message tells me I dont have access to Meetings, yet as confirmed by a support tech last night checking my account, it most definitely is.

 (The support tech thought perhaps the activation of the Meetings App in connection with the account had not occurred which should happen as a default.)

I am unable to connect to ANY active Meetings ID. Even with a current ID number with colleagues attending the Meeting at that very time I am still returning an Invalid Room ID. 

However when I use the iOS app, I can join ALL of the Meeting ID numbers that failed via the desktop app, with ease. The exact same numbers that the Desktop app tells me are invalid! 

I would hope that my account can also be included alongside everyones here. 

(I have used the online Chat support twice to try and resolve this issue, the first time I gave all the details of my system so they knew that the issue was not due to any of the settings. I was told that the Meeting ID must no longer be in use so therefore invalid. After I explained again, I was told my computer's firewall was the issue. After it was confirmed the firewall settings were correct I was then told that there might be an issue with my wifi connection. After I explained I was connected directly via ethernet with a connection speed of 90Mbps, I was told again that the Meeting ID must no longer be current. Thankfully the second support tech trusted what I was telling them, they said they would check with the RingCentral account manager responsible for my account who may know more.)


1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Good Leather Boy avatar image
Good Leather Boy Suspended answered
I'm having the exact same issue on my iMac running macOS Mojave. The Ring Central Meetings application was running perfectly fine last week, went to login two days ago and got the "Check Network Connection ....." warning. I hadn't even used my computer since the last time I used Meetings so it's literally impossible that any macOS updates or any changes at all to occur to my iMac's operating system. 

I've tried to completely rest the network configuration, switched from Wifi to Ethernet, factory reset my router, call my ISP provider and had them reset my connection on their end and when none of that works combined with 3 hours on the phone with Technical Support going "I don't know" I factory reset my iMac. After a fresh clean reinstall of macOS Mojave, no restores or data transfers from Time Machine and only system setup done was connecting to Wifi [didn't login to iCloud, didn't activate Keychain, Siri, Location Services, absolutely nothing] I used the default browser Safari as is, and went to entered the "Video Meeting ID" and clicked "Join Meeting" where as normal the Ring Central Meetings app pkg for macOS immediately downloaded and I proceeded to install as per the User Guide. I let the app do it's thing, the app started opening up the login/join meeting/sign up window, and immediately a pop-up appeared so "Invalid Meeting Number" [which it wasn't cause my partner was in that Video Meeting on his PC, in the same room, on the same network connection]. I clicked to close the pop-up window, clicked "Login" and entered my user account email, then password [which I did incorrectly getting "This email and password do not match" so obviously there is a network connection to validate my credentials right?], re-entered my password correctly, clicked "Sign in" and the app responded as as normal [timing & windows adjusting] but the instant the main window is opening [got like a very quick flash of the main window opening] the window shrank, resizing into a square window say "Network Connection ..." 

The fact the Meeting app verified my user credentials shows it can connect to my iMac's network. Since my operating software version is same when Meetings worked with no issue that's not the issue. Home Network & ISP not as they where reset to factory default also, no port mapping or advance configuration that's not mostly likely causing the problem. The fact that when going to uninstall the Ring Central App and plug-ins and remove any possible associated cache, cookies or log files I realized something vey strange ... the Meetings app for macOS had been installed in 3 different file locations, all with separate library files;

1) in the "Applications" folder
2) In the "Desktop" folder [2 apps identical apps here actually]
3) In the "Downloads" folder

I thoroughly checked, reviewed, analyzed each one and they were "aliases" but completely different apps which totally separate from each other. Strange to the "Ring Central" folder where recordings are saved had also been created somehow [which in my Ring Central online account is turned off].

Maybe it could be possible the issue lies with Ring Central services and actually nothing to do with macOS operating systems? 

So my question is, has this issue been resolved? If not, when can macOS users expect one?

Thank you 
1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

guy4pigplay14091 avatar image
guy4pigplay14091 Suspended answered Aloke Nath commented
Apologies. I have been very busy and have not checked back in. Let me share what I know, including a work-around that might help some of you.

  • My connection issue has been escalated to Tier 3 Tech Support, which is actively working with RingCentral's partner (I assume that's Zoom) to resolve the issue.
  • At the request of RingCentral's Tier 2 Tech Support, I installed a special version of the RC Meetings client for Mac that creates diagnostic logs, which captured a lot network information. The logs have been sent to Tier 3 support.

Here is how you might be able to work around the problem. This solution worked for me. Hopefully, it will for you, too.

Create a new user account
Make sure you're logged in to account with Admin control over you Mac.
  1. Go to System Preferences --> Users & Groups.
  2. Click the padlock in the lower left of the dialog box that appears and enter the password for admin account you logged in from.
  3. Click the + in the lower left above the padlock icon to add a new user account.
  4. Complete the panel that appears. Choose Standard or Administrator from the New Account drop-down menu. Make sure to choose a password you'll remember and keep it somewhere safe.
  5. Click Create User.
  6. When the new user appears in the user list on the left, close System Preferences.

Launch the new user account

To log in to your Mac using the new account you just created, consider these options:
  1. Disable Automatic Login in Systems Preferences --> Users & Groups if it's enabled. This will let you choose the account you want to use to start up with each time you log in.
  2. Restart your Mac and click the icon for the new user account you just created when it appears on the screen.
  3. If you have Fast User Switching turned on, you can use it to switch accounts without rebooting.
Tip: Understand multiple accounts and Fast User Switching on a Mac.

Launch the RC Meetings app from the new user account
  1. Locate the RingCentral Meetings app in the Applications folder on your Mac and double click its icon.
  2. A panel should open prompting you to log in to RingCentral Meetings account. Enter your username and and password.
  3. If the log-in is successful, you should see the RingCentral Meetings floating menu panel appear in the top right of your screen.
  4. Click Settings (the gear icon) to set your general, audio, video, and meeting preferences, which will be unique to the new account you created.
  5. Start or Join a meeting to test RC Meetings is working correctly Note: Your recent meetings list will be empty. Your scheduled and recorded meetings probably will be missing, too. They're stored with the user account, not in the cloud or inside the app itself.
Let me know if this workaround works for you. I know creating a new account might sound a bit extreme, but it only takes a few minutes. Having to reboot as a different user each time you want to use RingCentral isn't the most convenient, but hopefully, it will only be temporary.

Best regards,

1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

cosshades-35414129 avatar image cosshades-35414129 commented ·
This works for me. Thank you so much Len. At least we have a temporary fix for now. Hopefully they get a real solution soon. Thanks again
1 Like 1 ·
trevor avatar image trevor commented ·
You left out one critical note; DO NOT SIGN BACK IN TO YOUR iTunes ACCOUNT! When you first log in with the new user, you follow typical setup steps, one of which is to sign into iCloud /iTunes /iEverything. If you sign in the issue continues, skip it and suddenly everything works. I believe the root of the problem has been located.
1 Like 1 ·
raw-d-nyc avatar image raw-d-nyc commented ·
Workaround was successful for me as well.
0 Likes 0 ·
guy4pigplay14091 avatar image guy4pigplay14091 commented ·
Hi Trevor,

Interesting. I never would have thought my iTunes account would have anything to do with it. I didn't mention it in my directions because I never considered it. It's great that you noticed this critical detail and have been able to share that information here. I wonder if I reboot into my original user account and disable my iTunes account if Zoom will start working again for that account. I will have to test it out and let you know. Kudos Trevor for this important detail.

0 Likes 0 ·
guy4pigplay14091 avatar image guy4pigplay14091 commented ·
Shades and Raw D - I am glad my solution worked for both of you. I assume neither of you logged back into your iTunes accounts as Trevor warns us not to. Just curious about your take on the iTunes connection.
0 Likes 0 ·
Show more comments
guy4pigplay14091 avatar image
guy4pigplay14091 Suspended answered
To recap quickly, I posted a workaround, which seems to be working for some RC Meetings users. Another user, Trevor, provides an additional tip to make the work around more bulletproof. His tip suggests a conflict between iTunes and the RC Meetings app, which would surprise me because bot applications include helper apps that run the background.

I have not heard anything more from Ring Central Tier 3 support regarding this issue. Tier 3 support team: Do you have anything to contribute?

Thank you to all of the RC Meetings users who have reached out to me directly or Me Too'd this issue to give it visibility. You rock!
1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Work together.
From anywhere.

Team messaging, video meetings
and phone - all in one app.

Get the new RingCentral app