Question

Unable to log in to RingCentral Meetings from one Mac. Problem is identical to Eduardo's

  • 14 February 2019
  • 38 replies
  • 2130 views

About 4 days ago, RingCentral Meetings on one of my Macs (MacMini i7, 16GB, running OSX 10.11.6) started exhibiting the same behavior as reported in the community forum by at least a half dozen users now. Every time I try to log in, RC Meetings reports I am not connected to the Internet, and I need to check my network connection. My Internet connection works just fine because I can connect to every other Internet service or website I use. I can even connect to the RingCentral Glip app. Because I can't log in, I am unable to connect to meetings and the floating window with Join Meeting / Start Meeting buttons won't load. FYI: I am running RC Meetings for Mac version 6.3.135305.1213, which is the most recent version as reported by the application itself.


At first, I thought the issue might be an account problem, but my tests demonstrated that wasn't the case. I was able to log in to my account from the web at service.ringcentral.com. Next, I attempted to use RC Meetings from my Mac laptop. Everything worked perfectly.


Now for the real clincher, I can log in to RC Meetings, and it works beautifully on the same Mac where I'm experiencing this issue when I boot the Mac from an external SSD running a slightly earlier version of MacOSX (version 10.10). The only variation I have noted is a report by the MacOS network traffic inspection utility, Little Snitch, which reports RC Meeting's digital signature is different when running from the external SSD partition than when booting from my primary internal SSD. Little Snitch's messaging is a bit cryptic, but it suggests the application isn't signed on the Mac partition I can't log in from. I opened the application package and did some snooping around, and I discovered this in the plist XML:



It kind of looks like there might be something missing, don't you think? Of course, I might be barking up the wrong tree, but I've given you a whole bunch of information to investigate and resolve this issue.


Let's review. I eliminated all of these possible variables:


  • Not a firewall issue: No firewall in operation; no ports are blocked.
  • Not an account issue: I can log in to my account from service.ringcentral.com. I can log in from my Mac laptop. I can log in on the Mac I'm experiencing the problem on when booting from an external SSD with an alternative version of the OS.
  • Not a router or ISP issue: All testing has been accomplished using the same router and ISP.
  • Not a computer hardware issue: I can connect from the same Mac that can't connect when booting a slightly earlier OS version from an external drive.


Jessica - If you are reading this I would argue you haven't been doing your job (or a very good job) by directing folks experiencing this issue to submit tickets to tech support. I have a free account, and I haven't found a way to submit a ticket or interact the support team on chat. I wanted to expedite resolution of this issue so I tried to buy a paid subscription two nights ago. I tried two different credit cards, but RC's payment gateway reported it couldn't process my cards. It wasn't telling me it could authorize charges to my card (which my bank would have notified me about) so it sounds like Ring Central' payment processing might be offline. No help there.


As a community evangelist, it's your role, Jessica, to act as a facilitator who elevates customer concerns so they get the visibility within your support organization necessary for quick resolution. I am very glad to see that you created a ticket for Edoardo Tuo, who IMHO was treated in a condescending, unhelpful manner by J.B. Ferguson, who, again in IMHO, is not the kind of person you want representing RingCentral and its brand.


Right now, I have a very lukewarm opinion of RingCentral's customer service and support organization, which is a great opportunity for you to convert me from a skeptic to a fan. I'd start by forwarding my email to your executive response team so they can connect with your developers in hopes of getting this issue resolved quickly and easily for everyone experiencing it.


Please send me the ticket number if you create a ticket for me. Thank you, and I look forward to hearing from you or someone else at RingCentral.


Len F.


38 replies

Identical problem with new MAC with most recent updates installed.
For the record, I am NOT a RingCentral employee nor do I represent RIngCentral and it's brand. I am a customer, just like those with paid accounts, who tries to help out here in the community based on our experiences and knowledge of the system.  I am not paid by RIngCentral nor compensated with a free account or anything else to help out here.

Furthermore, my responses to Mr. Tuo were hardly condescending and it seems that those in the community are only "helpful" in your eyes if they solve a person's issue. I simply made recommendations and asked questions, which only one question of the ones I asked was answered by Mr. Tuo. My track record of helpful responses speaks for itself with 887 likes on 1,410 responses.

You, of course, are entitled to YOUR opinion. But unless you work or have worked at RIngCentral and know what Jessica's job description is and what her job entails, I would only conclude that your comments to her were very condescending and certainly were not helpful.

I'm done with this entire issue.



Hi Len, 

I have escalated your issue to our Executive Response Team. Your case number is 08286495 and someone will be reaching out to you soon! 
Jessica I have the same problem as well 

I, as well am having the same issue. Mac mini mid 2014, Mac OS 10.14.3 supplemental. Ring central is the only app that will not connect to the network. Just as above I can login to Meetings via my phone or the browser account page, just not the desktop app
Same issue here. 2017 Retina 4k iMac Mojave 10.14.3
Hi 

As with everyone above I have similar issues. 

Mac is 2 years old, Mojave 10.14.3, the RingCentral Desktop app is up to date. 

I am unable to login to the RingCentral desktop app even though I am a PAYING customer! The message tells me I dont have access to Meetings, yet as confirmed by a support tech last night checking my account, it most definitely is.

 (The support tech thought perhaps the activation of the Meetings App in connection with the account had not occurred which should happen as a default.)

I am unable to connect to ANY active Meetings ID. Even with a current ID number with colleagues attending the Meeting at that very time I am still returning an Invalid Room ID. 

However when I use the iOS app, I can join ALL of the Meeting ID numbers that failed via the desktop app, with ease. The exact same numbers that the Desktop app tells me are invalid! 

I would hope that my account can also be included alongside everyones here. 

(I have used the online Chat support twice to try and resolve this issue, the first time I gave all the details of my system so they knew that the issue was not due to any of the settings. I was told that the Meeting ID must no longer be in use so therefore invalid. After I explained again, I was told my computer's firewall was the issue. After it was confirmed the firewall settings were correct I was then told that there might be an issue with my wifi connection. After I explained I was connected directly via ethernet with a connection speed of 90Mbps, I was told again that the Meeting ID must no longer be current. Thankfully the second support tech trusted what I was telling them, they said they would check with the RingCentral account manager responsible for my account who may know more.)

 

I'm having the exact same issue on my iMac running macOS Mojave. The Ring Central Meetings application was running perfectly fine last week, went to login two days ago and got the "Check Network Connection ....." warning. I hadn't even used my computer since the last time I used Meetings so it's literally impossible that any macOS updates or any changes at all to occur to my iMac's operating system. 

I've tried to completely rest the network configuration, switched from Wifi to Ethernet, factory reset my router, call my ISP provider and had them reset my connection on their end and when none of that works combined with 3 hours on the phone with Technical Support going "I don't know" I factory reset my iMac. After a fresh clean reinstall of macOS Mojave, no restores or data transfers from Time Machine and only system setup done was connecting to Wifi [didn't login to iCloud, didn't activate Keychain, Siri, Location Services, absolutely nothing] I used the default browser Safari as is, and went to https://meetings.ringcentral.com/join entered the "Video Meeting ID" and clicked "Join Meeting" where as normal the Ring Central Meetings app pkg for macOS immediately downloaded and I proceeded to install as per the User Guide. I let the app do it's thing, the app started opening up the login/join meeting/sign up window, and immediately a pop-up appeared so "Invalid Meeting Number" [which it wasn't cause my partner was in that Video Meeting on his PC, in the same room, on the same network connection]. I clicked to close the pop-up window, clicked "Login" and entered my user account email, then password [which I did incorrectly getting "This email and password do not match" so obviously there is a network connection to validate my credentials right?], re-entered my password correctly, clicked "Sign in" and the app responded as as normal [timing & windows adjusting] but the instant the main window is opening [got like a very quick flash of the main window opening] the window shrank, resizing into a square window say "Network Connection ..." 

The fact the Meeting app verified my user credentials shows it can connect to my iMac's network. Since my operating software version is same when Meetings worked with no issue that's not the issue. Home Network & ISP not as they where reset to factory default also, no port mapping or advance configuration that's not mostly likely causing the problem. The fact that when going to uninstall the Ring Central App and plug-ins and remove any possible associated cache, cookies or log files I realized something vey strange ... the Meetings app for macOS had been installed in 3 different file locations, all with separate library files;

1) in the "Applications" folder
2) In the "Desktop" folder [2 apps identical apps here actually]
3) In the "Downloads" folder

I thoroughly checked, reviewed, analyzed each one and they were "aliases" but completely different apps which totally separate from each other. Strange to the "Ring Central" folder where recordings are saved had also been created somehow [which in my Ring Central online account is turned off].

Maybe it could be possible the issue lies with Ring Central services and actually nothing to do with macOS operating systems? 

So my question is, has this issue been resolved? If not, when can macOS users expect one?

Thank you 
Apologies. I have been very busy and have not checked back in. Let me share what I know, including a work-around that might help some of you.

  • My connection issue has been escalated to Tier 3 Tech Support, which is actively working with RingCentral's partner (I assume that's Zoom) to resolve the issue.
  • At the request of RingCentral's Tier 2 Tech Support, I installed a special version of the RC Meetings client for Mac that creates diagnostic logs, which captured a lot network information. The logs have been sent to Tier 3 support.

Here is how you might be able to work around the problem. This solution worked for me. Hopefully, it will for you, too.

Create a new user account
Make sure you're logged in to account with Admin control over you Mac.
  1. Go to System Preferences --> Users & Groups.
  2. Click the padlock in the lower left of the dialog box that appears and enter the password for admin account you logged in from.
  3. Click the + in the lower left above the padlock icon to add a new user account.
  4. Complete the panel that appears. Choose Standard or Administrator from the New Account drop-down menu. Make sure to choose a password you'll remember and keep it somewhere safe.
  5. Click Create User.
  6. When the new user appears in the user list on the left, close System Preferences.

Launch the new user account

To log in to your Mac using the new account you just created, consider these options:
  1. Disable Automatic Login in Systems Preferences --> Users & Groups if it's enabled. This will let you choose the account you want to use to start up with each time you log in.
  2. Restart your Mac and click the icon for the new user account you just created when it appears on the screen.
  3. If you have Fast User Switching turned on, you can use it to switch accounts without rebooting.
Tip: Understand multiple accounts and Fast User Switching on a Mac.

Launch the RC Meetings app from the new user account
  1. Locate the RingCentral Meetings app in the Applications folder on your Mac and double click its icon.
  2. A panel should open prompting you to log in to RingCentral Meetings account. Enter your username and and password.
  3. If the log-in is successful, you should see the RingCentral Meetings floating menu panel appear in the top right of your screen.
  4. Click Settings (the gear icon) to set your general, audio, video, and meeting preferences, which will be unique to the new account you created.
  5. Start or Join a meeting to test RC Meetings is working correctly Note: Your recent meetings list will be empty. Your scheduled and recorded meetings probably will be missing, too. They're stored with the user account, not in the cloud or inside the app itself.
Let me know if this workaround works for you. I know creating a new account might sound a bit extreme, but it only takes a few minutes. Having to reboot as a different user each time you want to use RingCentral isn't the most convenient, but hopefully, it will only be temporary.

Best regards,
Len









To recap quickly, I posted a workaround, which seems to be working for some RC Meetings users. Another user, Trevor, provides an additional tip to make the work around more bulletproof. His tip suggests a conflict between iTunes and the RC Meetings app, which would surprise me because bot applications include helper apps that run the background.

I have not heard anything more from Ring Central Tier 3 support regarding this issue. Tier 3 support team: Do you have anything to contribute?

Thank you to all of the RC Meetings users who have reached out to me directly or Me Too'd this issue to give it visibility. You rock!
Thank you everyone for continuing to provide details on your situations-- I keep forwarding your comments regarding what versions you are using to Tier 3 and the Executive Response Team. I'm glad Len found a workaround that seems to be working for some people! I'll post when I have more info! 
I'm on Mojave 10.14.1 and experiencing identical issues.   Len, your workaround works.   Thanks.   May I post in a few user forms that are a cross-over between Zoom and RingCentral?   The guys there are dying for help.   I wont use your name.

I too have been experiencing all of the above issues. I am working on a MacBook Pro 2017 running the most current releases of OS and RC. I used the workaround That Len suggested and was delighted to find it worked, for about a day. I have had to create a new account almost every other day in order to access. I also tried running parallel platform and downloading a windows version of RC, so I didnt have to log out of my account each time. It works for them most part. Only issues being camera control, just takes a bit of time connecting a cam, just a lot of paths that need connecting. Just thought Id share my experiences for what its worth.
I too have the same issue .. 
      perhaps its because I am getting older or perhaps the world is wearing me down .. but I find it absolutely amazing that this number of people reporting the same issue has gone on unresolved for at first hours  and hours , then days and days ...and now weeks and weeks.. and still nothing, not even an official statement from the company ,that I have found , and little Jessica , who I am sure is a very nice girl , is in over her head or so it appears ...then it dawned on me, like the rest of life its a numbers game ..and I would guess we don't pose much of a financial incentive to warrant time being spent  to resolve this issue ... we are Mac users, individuals , by in large non paying accounts .. I would guess that this App like so many was written for PC, Mac inclusion was probably a thrown together re-write , we are not corporations with  large pools of users paying big  monthly fees to use this service .. its sad but it certainly would appear that RingCentral would, I am sure, prefer to see us all just go away...  this kind of blatant  institutional discrimination pretty much blows and really has no place in todays age...do we all remember what happened to ICU2? RingCentral is just another ICU2.....  the clock is ticking RingCentral ..   why on Earth would you offer no charge user accounts and then drag your feet .. like molassas in January .. if you had no intentions on resolving any of its issues? .. you people can clearly do better than this .
This reply was created from a merged topic originally titled CANT LOG IN RINGCENTRAL!!! need help ASAP. I registered yesterday on ring central, i downloaded the app on my mac but i cant log inside. It ask me for my email and then my password and after that i always recive this error. While from
my iphpne i can log in without any problem and im using same wifi connection.
how can i do to sole the problem please? i already tried to unistall and install again the app on my maca.
any solution plpease?
i need to use it ASAP! thx u
W
Still waiting for a resolution, myself... It is quite irritating to have to make a new user profile any time I want to go to a friends meeting... The thing I don't understand is that zoom just keep getting better and better and have no problems with meetings over zoom. Can't you guys just throw some more money at and buy some more stuff from them.. Their program is all in one and RC has what 3... It's very messy and confusing to begin with. Whatever zoom is doing is the model that should be followed because since I started using RC I think it's just bat shit crazy.. Just my two cents. Wondering if I'll ever be able to sign into a room normally without dealing with this Mickey Mouse of a band-aide .
Hey Y'all,  
I to have had problems logging into rooms from my mac,  I have created a new user account but that only worked for about a day,  then the same issue occurred with the new account.
I have had much better results by logging in through the "guest" account on my mac.  This seems to work day after day,  with much fewer issues.
The guest account deletes all files created during your time logged in when you log out of the account.  Makes me wonder if it is a file issue,  that is causing this "Mac Bug" ?  

Just throwing this out there to see if anyone has any thoughts about this.
Seriously what is taking so long for this fix? Its a bit ridiculous, and whats with a work around were you cant even use your own user account [seriouls how did they even come up with that and think it would actually work?]
Any progress? We need to make video calls as part of our business on a regular basis.

Potential to login to Zoom as a temporary fix - will RC cover the cost of our logins working with Zoom for the time being?
Hello Everyone,

The below instructions should help while Zoom continues to work on the issue.

  1. Click on the search option in the top right of your desktop
  2. Search for ~/Library/Preferences/ then select Preferences.  This will open up the Finder.
  3. In Finder, search for the file named ZoomChat.plist
  4. Right click on 'ZoomChat.plist', and select Move to Trash.
  5. Uninstall RC Meetings. Back in Finder, navigate to Applications.  Find RingCentral Meetings, right click and select Move to Trash.
  6. (If Applicable) Uninstall Zoom. Back in Finder, navigate to Applications.  Find Zoom.us, right click and select Move to Trash.  
  7. Right click on the Trash Can in the bottom right and select Empty Trash.
  8. Restart your Mac. 
  9. Reinstall RingCentral Meeting which can be found here: https://success.ringcentral.com/lc/cms/downloads
Okay guys, here is the only solution that actually worked for me after trying everything.

1.) go to /Applications/Utilities and open the Terminal
2.) type  "cd /Applications/RingCentral Meetings.app/Contents/MacOS/" WITHOUT PARENTHESIS
This will put the working directory in the RingCentral Meetings app itself
3.) you need to run the app with admin rights (not sure why but its the only think that fixed it)
so type "sudo ./RingCentral Meetings" WITHOUT PARENTHESIS
4.)Login like you would normally login.
hope it helps
Just noticed and received a pop-up before it crashed again- Ring Central has not moved to 64 bit yet.  Only one of my other apps is 32 bit and constantly crashes.  This combined with RC's need to connect to the internet browser for sign in while the handler is 64bit might be causing issue.  When is RC releasing a 64bit app?
Looks like I'm in the same boat.  I can only use this in my phone now, all our Macs are now down after what appears to be a recent RM update.  This is on both OSX 10.13.6 and 10.14.  I am updating one machine to 10.14.2, but from what I see here, it probably wont work. Will need to buy another meeting account to get by for now as getting right apps/sharing to appear on new user will be too cumbersome.
 [I am on a Mac (OS X 14.3) and RC Meetings ver. 6.315305.1213]

This is a poor workaround, but for me has been effective. Hopefully the issue can be resolved, but I have found that when I log in on my standard computer user account, I could not log in. I created a second user account and found I could log in. But, soon after, had the issue reappear on the new user account. So, then I tried using the guest account, and since documents and settings are not saved, I am able to log in to my account via the desktop application (for now, that is). 
I only just started experiencing this issue today on a meeting I ended up rescheduling. I'm able to log in as host on my iOS devices and also on a Mac that I rarely use for meetings which has an older version of the RC Meetings app on it.

The other weird thing is that I can log in using my Zoom.us account as a host (this is the company RingCentral licenses their Meetings technology through), so clearly this is an issue with the latest version of the RC Meetings app.

Sorry, but I'm not going to be creating a separate user account on my Mac just for this. It's less of a pain for my phone to act as host and then my Macbook to log on as a user.

Hopefully, we'll see a fix soon.

Reply