Maddie Jones avatar image
Maddie Jones asked Adam D. Ramczyk commented

Desk Phones do not ring

Hello. I have a Cisco desk phone, mobile app and desktop app with RingCentral. The mobile and desktop work perfectly. However, whenever I get a call my Cisco desk phone it does not ring or show that there is an incoming call. It is not an issue with the volume because it does not even register the call or show on the screen that I have an incoming call. I can make calls out from the Cisco phone, so I know that the phone connection works it just does not alert me for incoming calls. I pick it up to try to answer on my Cisco but it is silent. I have to answer only on app or desktop.

Please advise.

Thanks in advance

1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

mary-community-moderator avatar image mary-community-moderator ♦♦ commented ·

Hi Maddie, check if your deskphone is enabled on your Call Forwarding Settings.

0 Likes 0 ·
Adam D. Ramczyk avatar image Adam D. Ramczyk commented ·

I have the same issue with two users in the firm. They are not getting incoming calls to their desk phones. It'll not ring at all- not even show the incoming call. Then after they close the call on the desktop application a minute later a ghost call will show up on the desk phone that is completely empty because the call is long over.

Were you ever able to fix this incoming calls not ringing the desk phone or being extremely delayed to ring the desk phone?

0 Likes 0 ·
ryan-gosling avatar image ryan-gosling Adam D. Ramczyk commented ·

this sounds too weird to actually be a bug. Most likely wrong settings.
Log in the admin portal > Users > click on the user > Call Handling

check if it is set to "Ring in order" or "Ring all at once". It should be "Ring all at once" if you want the app and the deskphone to ring simultaneously.

If it actually is already set correctly, I would try to change the ringing time for the app to "Always Ring". This means it rings for 6 rings/ 30 seconds??? It's worth testing.

If those things don't help you. Try disabling the app form the blue slider and leave only the deskphone active. If you dial the employee line, will there still be a delay in the call? This would be a very good indication that the problem stems from RingCentral and not from incorrect settings.

Example pic:


0 Likes 0 ·
capture-1.png (32.2 KiB)
Adam D. Ramczyk avatar image Adam D. Ramczyk ryan-gosling commented ·

These are already the user's settings. They have also been triple checked as we even had RingCentral Support at one point the past three weeks attempt to help. At the moment I am testing to see if simply forcing the desk phone to ring first will resolve her issue at the moment. Though this is seriously frustrating for this user as it's our receptionist- so she gets the most calls by far from anyone.

0 Likes 0 ·
ryan-gosling avatar image ryan-gosling Adam D. Ramczyk commented ·
On the other hand even with incorrect settings, if your employees did answer the call on the app, there shouldn't be a ghost call...
0 Likes 0 ·
Adam D. Ramczyk avatar image Adam D. Ramczyk ryan-gosling commented ·

This one happened only to the second user with this issue. It's extremely weird. The first (our receptionist) simply has the incoming calls delayed going to the desk phone but no phantom calls if they miss the call as it goes to our voicemail box. The second user would get phantom calls about 30 seconds after ignoring it on her desktop application.

0 Likes 0 ·
Show more comments

0 Answers

Work together.
From anywhere.

Team messaging, video meetings
and phone - all in one app.

Get the new RingCentral app