Question

Block incoming calls when user is on an active call or RC Meeting

  • 3 January 2020
  • 2 replies
  • 1853 views

When a user is on an active call or logged into a RingCentral meeting, they still receive the pop up for incoming calls and the ring/notification. This is especially frustrating for call queue members who are on support calls with clients or on a RC Meeting assisting a client and they are continually receiving incoming calls. How can we set it up in RingCentral at a user or call queue level to not pop up and ring a user who is on an active call or on a RingCentral meeting? I have been chatting with RC Support and searching the support and community posts and have not been successful in resolving this. Can anyone help?


2 replies

Hi Shannon, 

If a user is in a call queue the system will continue to ring them as long as they show available. If they are on a call, they should be showing as unavailable but if they are in an RC meeting it will not auto change their status-- they'll need to manually change themselves to unavailable if they do not want to continue to receive call queue calls while in an RC meeting. 

If someone calls their direct line, it is always going to ring unless they change their status on their softphone to DnD, in which case they will not be able to receive calls from anyone. It doesn't matter if they are on a call queue call or in a meeting, it will ring and there isn't a way around it without blocking all incoming communication to their line through DnD. A call queue call shouldn't ring if they are on a active call because their extension should be showing as busy.

If you're still experiencing issues, I recommend that you should open a support ticket with specific call examples of the instances/ issues. 


Is there an option to stop any calls from coming in when the user is already on a call or there is still no feature in RC to change this behaviour?

Reply