Ignore calls during Meeting?

  • 16 September 2020
  • 4 replies

My users recently reported (and I confirmed with my own testing) that RC Phone and RingCentral are now allowing calls through during an active RingCentral Meeting session. This previously wasn't the case, and I have been told by RingCentral support that this is an intended "enhancement". Has anyone found a workaround, besides setting yourself to DND?

For the RingCentral staff: if this is truly an intended enhancement, I recommend reversing that decision. Being in a RingCentral Meeting (at least in a business setting) generally means you don't want to be disturbed unless it's important. And for situations that are so important that it can't wait for the meeting to be over, there are usually other methods of reaching someone, such as a cell phone.

4 replies

Will someone from RingCentral confirm this is intended functionality on this post? I agree and my users are not happy with being interrupted in meetings. The reality is someone is in a meeting and their RingCentral desktop app and mobile apps starting ringing mid sentence. They have to ignore the call or send it to voicemail then apologize to everyone for the interruption. Please, please, please address this.

Has there been an activity on this issue? We are new to RingCentral, but I agree that it would be best if calls were silenced or sent to voice mail while the user is in an RC Meeting or RC Video session. It appears the only option is for the user to manually set their account to DND.

Not only this but you can not ignore a ringcentral call on your app, if you hit ignore the call just come back and keeps ringing... ridiculous

Userlevel 1

It is correct that you have to manually set yourself to DND, however, we have an idea in the Ideas Portal that we encourage you to vote on so we can prioritize with the Product Team.