Question

Ringcentral desktop and Plantronics (Poly) headset USB connection cutting out

  • 13 June 2023
  • 4 replies
  • 1450 views

Hello,

I use an oldish but fantastic Plantronics headset C052A connected with a APU-76 USB adapter, on my W11 PC. I also use a Jabra desktop speaker on the same PC, USB connected.

Both work 100% perfectly in Teams and Zoom. I can switch between them during a call and they both work reliably, and the headset never skips a beat.

In Ringcentral (Desktop: 23.2.21.7380 Windows (x64) 2023-05-18 07:03:19) the Jabra works 100% OK. The Plantronics headset keeps cutting out. This is random and generally lasts for a few seconds, then sound is re-established. In a 5 min call this happens 4 or 5 times. When it cuts out, the headset "clicks" and both incoming and outgoing sound are muted. There isn't a repeatable pattern to this. This also happens when the Jabra is disconnected.

I have tried downloading and using the Plantronics hub software (https://www.poly.com/gb/en/support/downloads-apps/hub-desktop) but it's no better with or without this running and allowing Ringcentral to manage my headset.

I have also replicated this exact setup on another PC in a different office with the same Jabra but different headset and cable - identical models. This PC is running W10 and exactly the same thing happens.

This must therefore be a problem in Ringcentral, and is very frustrating for myself and callers.

Ideas or solutions very welcome

Rob


4 replies

We have a ton of issues with our Plantronics headsets, and have tickets in for this... call quality issues, the Plantronics HUB not recognized when RingCentral is first loaded in the morning. I have troubleshooted my heart out and cannot figure this out. Have you tried using app.ringcentral.com? or tested using their RC Phone App? Not sure if that app is still 100% relevant, but I have found some of the issues we have don't exist within that app. Just the desktop application and the browser version of Ring. We have also worked with our Managed IT Vendors thinking it was firewall or network issues, but to no avail. I truly believe it is this application, but we've gotten no relief with Ring. I think we've been having these issues for about a year now with ebbs and flows of going hard trying to troubleshoot because our users are getting sick of it, and then giving up because we get nowhere. It's truly frustrating. Good luck on your quest to find a solution. If you do, please try to post back to the community. Thanks!

Not sure if this will help, but there is a fix for the HUB not being recognized coming out sometime early July. Heads up in case that helps resolve any of your issues! Release 23.2.30.

Also be sure you've updated your firewalls, they just released new IP ranges (not sure if it means for all customers or just our region). The full article is here:

https://support.ringcentral.com/network-and-system-requirements/network-requirements/network-requirements-MVP.html?language=en_US

We regularly see issues with Plantronics headsets. Volume levels that go to almost nothing until we go into HUB software and change the output device to something (anything) else and back to the headset and then it works ok for a while. No call coming in but the headset rings like there is. Random beeping like Morse Code for a few min. None of it is reproducible on demand. Plantronics has the best form factor (light weight, over the ear) and battery life, but usability has gone downhill. This is just for the USB headsets paired with the softphone. The Plantronics that plugs into the back of a desk phone work great. But the feature that lets the softphone control the deskphone is still in Beta, so not much help there.

Not sure what else to do other than try Jabbra or Yea Link. Tired of futzing around with Plantronics.

Thank god I found you guys. Did you resolve your issues? only suddenly headset not working properly, lots of connectivity issues, thought it was the new crappy headset I bought but replaced with a not so crappy and that didn't work either then same on Plantronics Voyager 5200 I bought yesterday. It just cuts in and out often. It seems to have got a lot worse in the last few weeks and RC support is terrible. Now the app is fine on my mac ( i have it on macbook, my imac and also on the windows (ugh) desktop in the office). It's on the Windows desktop I have issues only. No issues it seems with mac. I have the old app on my imac and I wonder as you mentioned it whether I should just revert back to that on the windows device. Any developments? Thanks.

Reply