Question

SalesForce Rincentral App Slow

  • 13 September 2018
  • 14 replies
  • 1262 views

Yesterday there was an email sent out by Ringcentral saying that they were going to be moving the Data Centers to Chicago, IL. This morning our Ring Central within Sales Force has been extremely slow. Making it hard to use our dispositions. Is ringcentral aware of this issue? Is there a fix? This is slowing our Sales team down.


14 replies

Hi Rene, are you still having issues today?
Hello,

The problem as been fixed today.
Actually spoke too soon. It started up again. With the same problem.
Hmmm...please open a Support Case so we can investigate!


We're seeing the same issue...running very slow. Like there isn't enough bandwidth to handle the task. I opened a case since there isn't a known issue or resolution here. I read the moving of data centers email as well.
This reply was created from a merged topic originally titled RingCentral for Salesforce not working. The RingCentral App for Salesforce has been acting up for the last 3 days. I have had to contact support multiple times and have received no response or updates. This is slowing down our whole sales team. Yes, I have tried multiple browsers. Yes, I have tried updating the software. Yes, my computer is plugged in. Please fix the software.
Rene, has there been any solution? The past few days we have had terrible delay between Salesforce and our RC desktop app. 
This reply was created from a merged topic originally titled Delay preventing use of click to dial. Salesforce. We have had issues in the past with a delay between clicking the phone number in Salesforce and the call/sound opening on the RC desktop app. This has been really bad the past week. Does anyone have solutions or workarounds? My sales team is having a lot of customers hang up because there is nobody there on our end.
We have a similar issue where it takes the RC Phone app and the Salesforce Call Adapter almost ten seconds to initiate the call after the user clicks on a phone number in Salesforce.  We are on version 6.3.  Did anybody find a solution to the slowness? Thanks!
hi Shaun,

Wanted to check if you are still seeing the delay in initiation of call?
Yes we are.  I've been working with Ross Recoter at RingCentral support.  My case number is 09194937.  I've had three or four phone calls with them at this point where I'm asked to reproduce the problem and then collect logs.  Although, nothing has yet to come of it.  With that being said, I narrowed it down to a problem between the Salesforce Call Adapter and the RC Phone desktop application.  If I change the Salesforce Call Adapter to utilize a Polycom Deskphone to initiate the call, there is no delay.  If I tell the Salesforce cal Adapter to utilize the RC Phone app to initiate the call, there is a consistent 7 second delay between clicking the number in Salesforce and the RC Phone app initiating the call.

Thank you so much Shaun for the details of the case. Yes, the root cause for the slowness is in the area of initializing and handoff of the call control to SoftPhone and we are working with the appropriate teams to investigate further on this issue. Using the desk phone is a good workaround until the issue if fixed.
Hi! We had this fixed in 6.4. Please also update or reinstall your softphone. Let us know if this delay still happens. Thanks for your feedbacks!

We saw this using the Ring Central Desktop App, but the RC Phone app appears to work much better.

Our symptom was that the CTD would click, the App would trigger and call, but the CTI in Salesforce simply wouldn't update.

Reply