question

Justin DiMatteo avatar image
Justin DiMatteo asked mary-community-moderator commented

Windows 10 Desktop App no longer opens

RC desktop app for Windows has stopped launching correctly as of today. It worked fine a couple days ago, and this PC's Windows 10 was last updated in March.

What occurs now when trying to either open or reinstall Ringcentral is four background processes will start, but nothing else. No application is visible or loads, even for a second.

I have tried completely uninstalling all traces of the app from the workstation, including the registry entries. Downloading and then attempting to run the installer from the website ends in the same result - a few background processes visible in Task Manager, but no visible application.

Running out of ideas since wiping it clean did not produce a different outcome.

ringcentral app
20 comments
1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

You can create a support case here and support team can help you in resolving the issue

0 Likes 0 ·

Hi @Justin DiMatteo, I see you haven't created a case yet. Please send your account details to community.support@ringcentral.com so I can escalate your problem to an App Specialist. Include your callback number and the most convenient time to call you. If you can provide us screenshots with an error, that will be great as well.

0 Likes 0 ·

Hi Justin, were you able to resolve your issue by any chance? We have logged a ticket with RingCentral support however so far they haven't been able to help us.

0 Likes 0 ·

Hi @Adam Gajdos, can I have your case number so I can check?

0 Likes 0 ·
Adam Gajdos avatar image Adam Gajdos mary-community-moderator ♦ ·

Hi Mary, I believe it's already being investigated by a few of your colleagues but here it is: 12631452. I would be more interested in whether anyone experienced this problem before and if so, how it got resolved?

0 Likes 0 ·
Show more comments


Gregory Kruger


I have this exact same issue happening at our medical facility. Put in a case hoping yours had been solved already but the techs are just sending me links to the installer and telling me to turn off my VPN. Currently typing out page long emails to doctors on why they have to access ringcentral through the web and why it's not my fault

0 Likes 0 ·

Hi Greg, no solution yet however RingCentral confirmed that it appears to be an issue on their end.

0 Likes 0 ·

I am having the exact same issue and have opened a case. Please advise!

,

THIS! I am having the exact same issue where 4 instances are opening in the task manager, but the application will not open. The app had been working for months and recently this became an issue. We have uninstalled, removed the Glip files that were installed in May of 2020 as someone suggested, and still, the application will not load.

0 Likes 0 ·
Show more comments

1 Answer

jenn-community-moderator avatar image
jenn-community-moderator answered

Hello guys!

We can now install the updated version.

Please download and install this link.

EXE: https://drive.google.com/file/d/1qKDcaeTX1u3NZnvBcpFDvpu8lLt1ZEUr/view?usp=sharing

MSI:
https://drive.google.com/file/d/1egCQqLb_YNOpD-u6-sVDDPpKq00idXnF/view?usp=sharing

We hope this is fixed for your affected users. Thank you!

1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Work together.
From anywhere.

Team messaging, video meetings
and phone - all in one app.


Get the new RingCentral app