Rob avatar image
Rob asked Rob commented

2 headsets - how to disable/make one preferred?

I have a Plantronics headset and Jabra speakerphone attached to my PC (W11)

Ringcentral keeps defaulting to the Jabra. In fact I never use the Jabra with RC (desktop application), so I want to either disable it completely, or at least make the Plantronics headset the default.

I have tried downloading each of the "apps" for the devices seperately, and also together. Nothing I do persuades RC that the Jabra isn't the main device. It always shows the Jabra as connected and active and the Plantronics as connected and not active.


This is possibly an interaction with Teams which I also use, and use both headsets for.

How can I just remove/disable the Jabra from RC?


ringcentral app
1660652877194.png (19.3 KiB)
1 |3000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

May I know what happens when you turn off the Jabra? Does your Plantronics not automatically connect?

0 Likes 0 ·


Here's with both plugged in:


And here is when I remove the Jabra from the USB


0 Likes 0 ·
1660725903583.png (20.0 KiB)
1660725934148.png (18.4 KiB)

Are you using Windows or MAC?

0 Likes 0 ·
mary-community-moderator avatar image mary-community-moderator ♦♦ mary-community-moderator ♦♦ ·

Sorry, I see you're using Windows. Would you please try to turn off the Headset controls in the app? Check if your Plantronics will work.

0 Likes 0 ·
Show more comments

0 Answers

Work together.
From anywhere.

Team messaging, video meetings
and phone - all in one app.

Get the new RingCentral app