question

holistic3603791 avatar image
holistic3603791 asked michael-lepurage commented

How to switch Softphone ringer from headset to PC speakers?

The desktop app should have the option to ring PC/laptop speakers even when headset is plugged in. 

I believe this feature was available in the old softphone version. 
Please make this "ring PC speakers" available so we don't have to keep plugging and unplugging our headset each time we leave our desk. 

If this feature is available in the current desktop app, then please email me back with instructions on how to set it. 
The tech support person I chatted with told me ringing PC/Laptop speakers while headset is plugged in does not work. 

Appreciate your looking into this. 
thanks 
General Topic
1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

andrew2014 avatar image
andrew2014 answered
This definitely works. Just set the ringer to the speaker you want to ring and not to the system default. That's all that's needed :)
1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

mike avatar image
mike Deactivated answered
1. Just click the Settings icon,.




2. Then Sound, and you'll see the drop-down to choose the Ringer of your choice.

1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

holistic3603791 avatar image
holistic3603791 answered michael-lepurage commented
I tried this before I called this in but it didn't work.  It still rings to my headset (3.5mm same as the one i use on my cellphone) when it is plugged in. Don't know if there is a need to adjust something on my laptop settings itself.
6 comments
1 |1500 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

I have this exact same issue, but if I change the PC default to speakers it plays my call audio through my speakers no matter what ringcentral output option I select. I try every single ring option in the app and it always just rings to my headset if I dont change the default
1 Like 1 ·
It's probably the sound settings on the PC.  Take a look at the audio/playback device default for the PC itself. 
0 Likes 0 ·
Update, i ended up finding a backdoor solution in sound settings that allowed for simultaneous audio through two sources, but it is real annoying. There has to be an easier fix.
0 Likes 0 ·
Same issue as Lucas. My default output is set to PC speakers and the RingCentral Phone app is also set to PC speakers, yet it only rings to my headset (plugged in via USB).
0 Likes 0 ·
Try: Control panel > Hardware and Sound > Sound > Recording Tab

There should be a device called Stereo mix. Open it up to make sure it is activated, and once it is activated you can set the options to play out of multiple audio outputs.
0 Likes 0 ·
Show more comments

Customer Spaces

Work together.
From anywhere.

Team messaging, video meetings
and phone - all in one app.


Get the new RingCentral app